

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://developers.facebook.com/schema/">
<head id="ctl00_PageTemplateHead"><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><meta name="viewport" content="width=device-width, height=device-height, initial-scale=1.0, user-scalable=0, minimum-scale=1.0, maximum-scale=1.0" />
    <script src="https://use.fontawesome.com/releases/v5.0.12/js/all.js" integrity="sha384-Voup2lBiiyZYkRto2XWqbzxHXwzcm4A5RfdfG6466bu5LqjwwrjXCMBQBLMWh7qR" crossorigin="anonymous"></script>

    <style>
        @import url("/Stylesheets/styles.css");
        @import url("/Stylesheets/ddsmoothmenu.css");
    </style>
    <!-- drop menu scripts -->
    
    <!-- Google +1 script -->
    <script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
    <!-- google ads -->
    <script type="text/javascript" src="http://partner.googleadservices.com/gampad/google_service.js"></script>

    <script type="text/javascript">
        GS_googleAddAdSenseService("ca-pub-5277869143274761");
        GS_googleEnableAllServices();
    </script>

    <script type="text/javascript">
        GA_googleAddSlot("ca-pub-5277869143274761", "StreamingMediaGlobal-Banners");
        GA_googleAddSlot("ca-pub-5277869143274761", "StreamingMediaGlobal-Leaderboards");
        GA_googleAddSlot("ca-pub-5277869143274761", "StreamingMediaGlobal-WideSkyscrapers");
        GA_googleAddSlot("ca-pub-5277869143274761", "StreamingMediaGlobal-SmallBoxes");
        GA_googleAddSlot("ca-pub-5277869143274761", "StreamingMediaGlobal-Interstitial");
        GA_googleAddAttr("Topic", "Video_Hosting_Delivery,Video_Content_Creation_Production,Video_Encoding_Transcoding");
    </script>
    <script type="text/javascript">
        GA_googleFetchAds();
    </script>

    <!-- END OF google ads -->
    <title>
	OTT Moves Toward Microservices as Speed Becomes an Issue - www.StreamingMediaGlobal.com
</title><link rel="shortcut icon" href="/favicon.ico" /><meta name="google-site-verification" content="HQ4pT1MuN_FBJz61-AOW1W8THi8zUzyDjmXsWnDJmMI" /><meta name="y_key" content="999888d39b86647f" /><meta property="og:site_name" content="Streaming Media Europe Magazine" /><meta property="fb:admins" content="1448114697" /><meta property="fb:admins" content="1398034021" /><meta property="fb:admins" content="692216861" /><meta property="fb:admins" content="100000228928066" /><meta property="fb:admins" content="682155031" /><meta property="fb:app_id" content="304779285740" /><link href="/cookie?v=0ZvVfDSn1pE9-ZijgkNHmMGWHcXH9bGsS4qX8Ycd1Dc1" rel="stylesheet"/>
<script src="/js-scripts?v=xeCxUpoQ2_JKIa_HegjLSJF2esDaZtalVLqUCf7LKsQ1"></script>
<script src="/custom-scripts?v=kJxI96OqUt2rlKw9F1eTzxe08EXRB8IKAT8YrWagXq01"></script>
<meta property="og:type" content="article" />
<meta name="title" content="OTT Moves Toward Microservices as Speed Becomes an Issue" >
<meta property="og:title" content="OTT Moves Toward Microservices as Speed Becomes an Issue" >
<meta name="description" content="Microservices architectures are central to the growth of OTT services, but they're widely misunderstood. Here's an intro to the major players. " >
<meta property="og:description" content="Microservices architectures are central to the growth of OTT services, but they're widely misunderstood. Here's an intro to the major players. " >
<meta name="medium" content="news" >
<link rel="image_src" href="http://dzceab466r34n.cloudfront.net/Images/ArticleImages/117638-Microservices-200.jpg" >
<meta property="og:image" content="http://dzceab466r34n.cloudfront.net/Images/ArticleImages/117638-Microservices-200.jpg" >
<meta name="summary" content="Microservices architectures are central to the growth of OTT services, but they're widely misunderstood. Here's an intro to the major players. " >
<meta name="published-date" content="20180831" >
<meta property="og:url" content="http://www.streamingmediaglobal.com/Articles/ReadArticle.aspx?ArticleID=127125" />
<link name="canonical" content="http://www.streamingmediaglobal.com/Articles/ReadArticle.aspx?ArticleID=127125" />
<meta name="keywords" content="Video Hosting/Delivery,Video Content Creation/Production,Video Encoding/Transcoding" >
<meta property="article:author" content="http://www.streamingmediaglobal.com/Authors/4268-Dom-Robinson.htm" />
</head>
<!-- begin header module -->
<body>
    <div id="fb-root"></div>
    <script type="text/javascript">    (function (d, s, id) {
            var js, fjs = d.getElementsByTagName(s)[0];
            if (d.getElementById(id)) return;
            js = d.createElement(s); js.id = id; js.async = true;
            js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=304779285740";
            fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));
    </script>
    <div id="ctl00_CookieSticky_pnlCookieSticky" class="cookie_sticky">
	
    <div class="cookie_sticky_detail">
        This website uses cookies to improve your user experience. By continuing to use this site you consent to the use of cookies on your device, as described in our <a href="http://www.infotoday.eu/privacy.aspx#cookies" target="_blank">cookie policy</a>. Parts of this website may not work as expected without cookies. To find out more about cookies, including how to manage and delete them, visit <a href="https://www.aboutcookies.org" target="_blank">www.aboutcookies.org</a> or <a href="http://www.allaboutcookies.org" target="_blank">www.allaboutcookies.org</a>.
    </div>
    <div class="cookie_sticky_close"><i class="fa fa-times" aria-hidden="true"></i></div>

</div>

    <form method="post" action="/Articles/Editorial/Featured-Articles/OTT-Moves-Toward-Microservices-as-Speed-Becomes-an-Issue-127125.aspx" id="aspnetForm">
<div class="aspNetHidden">
<input type="hidden" name="__EVENTTARGET" id="__EVENTTARGET" value="" />
<input type="hidden" name="__EVENTARGUMENT" id="__EVENTARGUMENT" value="" />
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="/wEPDwUKMTEyOTIzOTI4M2RkR2Vv2yszMBaO3cJTBfCL6DBVE0zstRYev2uovNU42O4=" />
</div>

<script type="text/javascript">
//<![CDATA[
var theForm = document.forms['aspnetForm'];
if (!theForm) {
    theForm = document.aspnetForm;
}
function __doPostBack(eventTarget, eventArgument) {
    if (!theForm.onsubmit || (theForm.onsubmit() != false)) {
        theForm.__EVENTTARGET.value = eventTarget;
        theForm.__EVENTARGUMENT.value = eventArgument;
        theForm.submit();
    }
}
//]]>
</script>


<script src="/WebResource.axd?d=niiH9Z4aHBQQwD59j-NvKmb1wTGp_10VYAfiwwDc0Ouljxo9om4nplJHLL87OWK_8Sfx_rNSHVQxkU7CsKlwfdHlpMcqiM04ljpM6074L8Q1&amp;t=636638374180000000" type="text/javascript"></script>


<script src="/ScriptResource.axd?d=BjMjhwD9iPKoyHQDDYX54_Q4TjAo4t8FvyFiP6VflVhH3X5ZisJf6zvIVHrsWtvjR0Lbwe95dRyuSVWEHcsnKFpOG0kxrZyCkKQ03MIVG-B49PyZ7g0yP8swEr2RMOsIQjMKsX3IS3o4aO5OPBDxtgxjr6cTdIzMAT98g3tFZZA1&amp;t=c328a10" type="text/javascript"></script>
<script src="/ScriptResource.axd?d=OMTbr3KFxcYm2CAXcHytNfz26lEW6Ph_5sTx27YwMLjf3PAFQa_KKe5MJJYsKrwTtBHGB0hAvB96IYhaT27YC_ydt3dVum9HUXtIDLa8C573lBNfBz_ofROgBbn0SXIHv0hcJaypONZy3hycDcCnv6NSfU-nggpRzTWce4vDdFpqk5Lf7iiIxazeBqlAkqgK0&amp;t=c328a10" type="text/javascript"></script>
<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="28F6BF4E" />
</div>
        <script type="text/javascript">
//<![CDATA[
Sys.WebForms.PageRequestManager._initialize('ctl00$ScriptManager_1', 'aspnetForm', [], [], [], 90, 'ctl00');
//]]>
</script>

        <div class="container">
            <div id="header">
                <div id="logo">
                    <a href="http://www.streamingmediaglobal.com">
                        <img src="http://dzceab466r34n.cloudfront.net/EuropeStreamingMedia/TemplateImages/SM_Europe_Logo2.png" width="268" height="77" style="border: none;" /></a>
                </div>
                <div id="adLeaderboard">
                    

<!-- begin doubleclick 728x90 module -->
<script type="text/javascript">
  GA_googleFillSlot("StreamingMediaGlobal-Leaderboards");
</script>
<!-- end doubleclick 728x90 module -->


                </div>
            </div>
        </div>
        
<div id="menuBar">
	<div id="smoothmenu1" class="ddsmoothmenu">
		<ul>
			<li><a href="http://www.streamingmediaglobal.com" title="Streaming Media Europe Home">Home</a></li>
				<li><a href="http://www.streamingmedia.com" title="StreamingMedia.com Home">U.S. Site</a></li>
				<li><a href="http://www.streamingmedia.com/Producer" title="Streaming Media Producer">Producer</a></li>
			<li><a href="http://www.streamingmediaglobal.com/Subscribe">Subscribe</a>
				<ul>
				<li><a href="http://www.streamingmediaglobal.com/Subscribe">Magazine</a></li>
				<li><a href="http://www.streamingmediaglobal.com/Newsletters" title="Preview Newsletter">Newsletters</a></li>
				<li><a href="http://www.streamingmediaglobal.com/RSS/Rss_feeds.aspx" title="RSS Feeds"><img src="/Images/TemplateImages/iconRss.gif" border="0" align="absmiddle" hspace="3">RSS Feeds</a></li>
				</ul>
			</li>
			<li><a href="http://www.streamingmediaglobal.com" title="Articles">Editorial</a>

				<ul>
				<li><a href="http://www.streamingmediaglobal.com/Articles/News" title="News">News</a></li>
				<li><a href="http://www.streamingmediaglobal.com/Articles/Features" title="Features">Features</a></li>
				<li><a href="http://www.streamingmediaglobal.com/PressRelease" title="Industry Announcements">Industry Announcements</a></li>
				<li><a href="http://www.streamingmediaglobal.com/Articles/SponsoredArticles" title="Sponsored Articles">Sponsored Articles</a></li>
				<li><a href="http://www.streamingmediaglobal.com/Previous_Issues" title="Magazine">Magazine</a></li>
				<!--<li><a href="http://www.StreamingMediaEurope.net" target="_blank">Blog</a></li>-->
				</ul>
      </li>
			<li><a href="http://www.streamingmediaglobal.com/StreamingMediaTV">Video</a>
				<ul>
				<li><a href="http://www.streamingmediaglobal.com/ConferenceVideos" title="Conference Videos">Conference Videos</a></li>
				<!--<li><a href="http://www.streamingmedia.com/RedCarpet" title="Red Carpet Interviews" title="Red Carpet Interviews">Red Carpet Interviews (U.S. Events)</a></li>-->
        <!--<li><a href="http://www.streamingmedia.com/AlmostLive" title="Online Video Expert Interviews">Almost Live Interviews</a></li>-->
				<li><a href="http://www.streamingmediaglobal.com/Tutorials" title="Video Tutorials">Video Tutorials</a></li>
<!--				<li><a href="http://www.streamingmediaglobal.com/SponsoredVideos">Sponsored Videos</a></li>-->
				</ul>
      </li>
			
<!-- begin categories module -->

    <li><a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl00_CaptionText">Topics</a>
        <ul>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl01_Category" href="http://www.streamingmediaglobal.com/Categories/Legal-Issues_448.aspx">Legal Issues</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl02_Category" href="http://www.streamingmediaglobal.com/Categories/Live-Streaming_579.aspx">Live Streaming</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl03_Category" href="http://www.streamingmediaglobal.com/Categories/Mobile-Video_444.aspx">Mobile Video</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl04_Category" href="http://www.streamingmediaglobal.com/Categories/Music-Radio_445.aspx">Music/Radio</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl05_Category" href="http://www.streamingmediaglobal.com/Categories/Online-Video-Platforms_446.aspx">Online Video Platforms</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl06_Category" href="http://www.streamingmediaglobal.com/Categories/OTT-Video_443.aspx">OTT Video</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl07_Category" href="http://www.streamingmediaglobal.com/Categories/Video-Advertising_440.aspx">Video Advertising</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl08_Category" href="http://www.streamingmediaglobal.com/Categories/Video-Content-Creation-Production_438.aspx">Video Content Creation/Production</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl09_Category" href="http://www.streamingmediaglobal.com/Categories/Video-Content-Protection-DRM_441.aspx">Video Content Protection/DRM</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl10_Category" href="http://www.streamingmediaglobal.com/Categories/Video-Encoding-Transcoding_439.aspx">Video Encoding/Transcoding</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl11_Category" href="http://www.streamingmediaglobal.com/Categories/Video-Formats-Players-Codecs_442.aspx">Video Formats/Players/Codecs</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl12_Category" href="http://www.streamingmediaglobal.com/Categories/Video-Hosting-Delivery_437.aspx">Video Hosting/Delivery</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl13_Category" href="http://www.streamingmediaglobal.com/Categories/Video-SEO_447.aspx">Video SEO</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_Topics_rptCategories_ctl14_Category" href="http://www.streamingmediaglobal.com/Categories/VR-and-360deg%3b-Video_590.aspx">VR and 360&deg; Video</a>
    </li>

        </UL>
   </li>

<!-- end categories module -->
			
<!-- begin categories module -->

    <li><a id="ctl00_NavMenu_1_CL_VertMarkets_rptCategories_ctl00_CaptionText">Verticals</a>
        <ul>

    <li>
	    <a id="ctl00_NavMenu_1_CL_VertMarkets_rptCategories_ctl01_Category" href="http://www.streamingmediaglobal.com/Categories/Education-Video_452.aspx">Education Video</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_VertMarkets_rptCategories_ctl02_Category" href="http://www.streamingmediaglobal.com/Categories/Enterprise-Video_450.aspx">Enterprise Video</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_VertMarkets_rptCategories_ctl03_Category" href="http://www.streamingmediaglobal.com/Categories/Government-Video_453.aspx">Government Video</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_VertMarkets_rptCategories_ctl04_Category" href="http://www.streamingmediaglobal.com/Categories/Media-Entertainment-Video_451.aspx">Media/Entertainment Video</a>
    </li>

    <li>
	    <a id="ctl00_NavMenu_1_CL_VertMarkets_rptCategories_ctl05_Category" href="http://www.streamingmediaglobal.com/Categories/Online-Video-Industry_449.aspx">Online Video Industry</a>
    </li>

        </UL>
   </li>

<!-- end categories module -->

			<li><a href="http://www.streamingmediaglobal.com">Resources</a>
      <ul>
			<li><a href="http://www.streamingmedia.com/Producer" title="Streaming Media Producer">Streaming Media Producer</a></li>
			<li><a href="http://www.streamingmediaglobal.com/Sourcebook" title="Industry Directory">Industry Directory (Sourcebook)</a></li>
			<li><a href="http://forums.streamingmedia.com/">Forums</a></li>
			<li><a href="http://www.streamingmediaglobal.com/Superguides" title="Superguides">Superguides</a></li>
			<li><a href="http://www.streamingmediaglobal.com/IndustryWhitepapers" title="Industry Whitepapers">Industry Whitepapers</a></li>
			<li><a href="http://www.streamingmediaglobal.com/Jobs" title="Jobs">Jobs</a></li>
			<li><a href="http://www.streamingmediaglobal.com/PressRelease">Press Releases</a></li>
			<li><a href="http://www.streamingmediaglobal.com/EventsDiary">Events Diary</a></li>
			<li><a href="http://www.streamingmediaglobal.com/ReadersChoice">Readers Choice Awards</a></li>
<!--	<li><a href="http://www.streamingmediaglobal.com/Research" title="Research Reports">Research Reports</a></li>-->
<!--	<li><a href="http://www.streamingmediaglobal.com/Glossary">Glossary</a></li>-->
      </ul>
     </li>
			<li><a href="http://www.streamingmediaglobal.com/Webevents" title="Web Events">Web Events</a></li>
			<li><a href="http://www.streamingmedia.com/Conferences" title="Conferences">Conferences</a>
      <ul>
			<li><a href="http://www.streaming-forum.com/" title="Streaming Forum">Streaming Forum</a></li>
			<!--<li><a href="http://www.streamingmediaglobal.com/Conference/2012/vis" title="Video Infrastructure Summit">Video Infrastructure Summit</a></li>-->
			<li><a href="http://www.contentdeliverysummit.com/" title="Content Delivery Summit">Content Delivery Summit</a></li>
			<li><a href="http://www.streamingmedia.com/conferences/East" title="Streaming Media East">Streaming Media East</a></li>						
      <li><a href="http://www.LiveStreamingSummit.com" title="Live Streaming Summit">Live Streaming Summit</a></li>			
			<li><a href="http://www.streamingmedia.com/Conferences/East2018/VideoMarketingPowerSummit.aspx" title="Video Marketing Power Summit">Video Marketing Power Summit</a></li>
			<li><a href="http://www.streamingmedia.com/conferences/West/" title="Streaming Media West">Streaming Media West</a></li>
			<!--<li><a href="http://www.enterprisevideoconference.com/" title="Enterprise Video Conference">Enterprise Video Conference</a></li>-->
			<li><a href="http://www.streamingmedia.com/Conferences">Past Conferences</a></li>
      </ul>
      </li>
			<li><a href="http://www.streamingmediaglobal.com/About/About_Us">About</a>
      <ul>
			<li><a href="http://www.streamingmediaglobal.com/About/What_Is_Streaming" title="What is Streaming?">What is Streaming?</a></li>
			<li><a href="http://www.streamingmediaglobal.com/About/About_Us" title="About Us">About Us</a></li>
			<li><a href="http://www.streamingmediaglobal.com/About/Contact_Us" title="Contact Us">Contact Us</a></li>
			<li><a href="http://www.streamingmediaglobal.com/About/How_to_Advertise" title="How to Advertise">How to Advertise</a></li>
			<li><a href="http://www.streamingmedia.com/Files/Download/SMEu_Editorial_Calendar" title="Editorial Calendar" target="_blank">Editorial Calendar</a></li>
			<li><a href="http://www.streamingmediaglobal.com/About/Editorial_Submissions" title="Editorial Submissions">Editorial Submissions</a></li>
			<li><a href="http://www.streamingmediaglobal.com/PressRelease/AddPressRelease.aspx" title="Press Release Submissions">Press Release Submissions</a></li>
      </ul>
    </li>
		</ul>
	</div>
</div>
        <!-- end header module -->
        <div class="container">

            <div id="body">
                <div id="ad468">
                    
<!-- begin doubleclick 468x60 module -->
<script type="text/javascript">
  GA_googleFillSlot("StreamingMediaGlobal-Banners");
</script>
<!-- end doubleclick 468x60 module -->

                </div>
                
    
<div id="bdyRight">

    <div align="center" style="margin-bottom:6px;">
        <div class="bglabel" style="padding: 4px; text-align: center; margin-bottom: 10px; font-weight: bolder; border: 1px solid #CCCCCC;"><a href="http://www.infotoday.eu/privacy.aspx" target="_blank">PRIVACY/COOKIES POLICY</a></div>

        
<div style="display: block; height: 30px; padding: 0px 0px 20px 0px; background: url(/images/TemplateImages/searchBg.gif) no-repeat; width: 300px;">
    <div style="float: left; width: 270px;">
        <input id="txtQuery" name="txtQuery" type="text" style="background: none; width: 265px; padding: 6px 0px 0px 5px; height: 20px; border: none; font: bold 12px Arial, Helvetica, sans-serif;" value="SEARCH STREAMING MEDIA EUROPE" onclick="this.value='';" />
    </div>
    <div id="SearchButton" style="background: none; width: 30px; height: 30px; border: none; cursor: pointer; float: right;" onclick="btnSearch_onclick()">
        &nbsp;</div>

    <script language="javascript" src="http://www.streamingmediaglobal.com/scripts/Search_Script.js"></script>
    <script language=javascript type="text/javascript">
var nav = window.Event ? true : false; 
if (nav) { 
	window.captureEvents(Event.KEYDOWN); 
	window.onkeydown = NetscapeEventHandler_KeyDown;
} 
else {
	document.onkeydown = MicrosoftEventHandler_KeyDown;
}
function NetscapeEventHandler_KeyDown(e) {
	if (e.which == 13 && e.target.type != 'textarea' && e.target.type != 'submit') {
		if (e.target.name == 'txtQuery') {
			document.location.href = '/Search/Default.aspx?Query=' +  escape(e.target.value);
		}
		return false;
	}
	return true; 
} 

function MicrosoftEventHandler_KeyDown() {
	if (event.keyCode == 13 && event.srcElement.type != 'textarea' && event.srcElement.type != 'submit') {
		if (event.srcElement.name == 'txtQuery') {
			document.location.href = '/Search/Default.aspx?Query=' +  escape(event.srcElement.value);
		}
		return false;
	}
	return true; 
}   
    </script>
</div>


      <div style="margin-bottom: 10px; margin-top: -10px;">
        <table class="tblStroke" style="width: 100%;" border="0" cellspacing="0" cellpadding="3">
<tbody>
<tr style="font-weight: bold;">
<td align="center">
<div class="redlabel">Upcoming Industry Conferences</div>
</td>
</tr>
<tr>
<td align="left">
<table style="width: 100%;" border="0" cellspacing="0" cellpadding="3">
<tbody>
<tr style="height: 13px;">
<td class="smallmenu" style="text-align: left; height: 13px;" bgcolor="#ffffff"><strong><a href="http://www.streamingmedia.com/Conferences/West2018/default.aspx">Streaming Media West</a>&nbsp;[13-14 November 2018]</strong></td>
</tr>
<tr style="height: 13px;">
<td class="smallmenu" style="text-align: left; height: 13px;" bgcolor="#dedede"><strong><a href="http://www.streamingmedia.com/Conferences/West2018/LiveStreamingSummit.aspx" target="_blank">Live Streaming Summit</a> [13-14 November 2018]</strong></td>
</tr>
<tr style="height: 13px;">
<td class="smallmenu" style="text-align: left; height: 13px;" bgcolor="#ffffff"><a href="http://www.streamingmedia.com/Conferences/"><strong>Past Conferences</strong></a></td>
</tr>
<tr style="height: 13px;">
<td class="smallmenu" style="height: 13px;" bgcolor="#dedede"><strong><a href="http://www.streamingmedia.com/east" target="_blank">Streaming Media East 2018</a>&nbsp;[8-9 May 2018]</strong></td>
</tr>
<tr style="height: 13px; background-color: #dedede;">
<td class="smallmenu" style="text-align: left; height: 13px;" bgcolor="#ffffff"><strong><a href="http://www.streamingmedia.com/Conferences/East2018/livestreamingsummit.aspx">Live Streaming Summit</a>&nbsp;[8-9&nbsp;May&nbsp;2018]</strong></td>
</tr>
<tr style="height: 13px;">
<td class="smallmenu" style="height: 13px;" bgcolor="#dedede"><strong><a href="http://www.contentdeliverysummit.com/2018/">Content Delivery Summit</a> [7 May 2018]</strong></td>
</tr>
<tr style="height: 13px;">
<td class="smallmenu" style="height: 13px;" bgcolor="#ffffff"><strong><a href="http://www.streaming-forum.com/2018/">Streaming Forum</a> [27 February 2018]</strong></td>
</tr>
</tbody>
</table>
</td>
</tr>
</tbody>
</table>
      </div>

        

<!-- begin doubleclick 300x250 module -->
<script type="text/javascript">
  GA_googleFillSlot("StreamingMediaGlobal-SmallBoxes");
</script>
<!-- end doubleclick 300x250 module -->


    <div style="margin-top:45px; margin-bottom:15px;">
        
<div class="tabBox">
    <div class="nav">
        <ul>
            <li id="rcBotLi1" class="tabOn"><a href="javascript:btnRC1('rcBot','1')">Popular</a></li>
            <li id="rcBotLi2" class="tabOff"><a href="javascript:btnRC1('rcBot','2')">Articles</a></li>
            <li id="rcBotLi3" class="tabOff"><a href="javascript:btnRC1('rcBot','3')">News</a></li>
        </ul>
    </div>
    <div class="body">
        <div id="rcBot1" style="display: block">
          <div class="bloglabel">Top 10 Most Popular Articles</div>
            
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_1_ctl00_rptArticles_ctl00_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/Asia-Pacific-Region-Will-Have-351M-SVOD-Customers-by-2023-126531.aspx" style="font-weight:bold;">Asia Pacific Region Will Have 351M SVOD Customers by 2023</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_1_ctl00_rptArticles_ctl01_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/OTT-Providers-Get-Higher-Marks-Than-Pay-TV-for-Customer-Service-126557.aspx" style="font-weight:bold;">OTT Providers Get Higher Marks Than Pay TV for Customer Service</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_1_ctl00_rptArticles_ctl02_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/European-TV-Watching-Shifts-to-On-Demand-Streamed-Content-126824.aspx" style="font-weight:bold;">European TV-Watching Shifts to On-Demand Streamed Content</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_1_ctl00_rptArticles_ctl03_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/Amazon-TV-Device-Owners-Are-Happier-With-Amazon-Prime-Video--127070.aspx" style="font-weight:bold;">Amazon TV Device Owners Are Happier With Amazon Prime Video</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_1_ctl00_rptArticles_ctl04_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/The-2018-Streaming-Media-European-Readers-Choice-Award-Winners-127092.aspx" style="font-weight:bold;">The 2018 Streaming Media European Readers’ Choice Award Winners</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_1_ctl00_rptArticles_ctl05_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/OTT-Moves-Toward-Microservices-as-Speed-Becomes-an-Issue-127125.aspx" style="font-weight:bold;">OTT Moves Toward Microservices as Speed Becomes an Issue</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_1_ctl00_rptArticles_ctl06_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/In-Defense-of-Autoplay-an-Unloved-and-Unmourned-Feature-127113.aspx" style="font-weight:bold;">In Defense of Autoplay, an Unloved and Unmourned Feature</a></div>
	
		<div>&nbsp;</div>
	

        </div>
        <div id="rcBot2" style="display: none">			
          <div class="bloglabel">Recent Featured Articles</div>
            
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_3_ctl00_rptArticles_ctl00_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/OTT-Moves-Toward-Microservices-as-Speed-Becomes-an-Issue-127125.aspx" style="font-weight:bold;">OTT Moves Toward Microservices as Speed Becomes an Issue</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_3_ctl00_rptArticles_ctl01_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/In-Defense-of-Autoplay-an-Unloved-and-Unmourned-Feature-127113.aspx" style="font-weight:bold;">In Defense of Autoplay, an Unloved and Unmourned Feature</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_3_ctl00_rptArticles_ctl02_ArticleTitle" href="http://www.streamingmedia.com/Articles/Editorial/Featured-Articles/Streaming-Video-Exploration-Makes-the-World-a-Little-Smaller-126097.aspx" target="_blank" style="font-weight:bold;">Streaming Video Exploration Makes the World a Little Smaller</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_3_ctl00_rptArticles_ctl03_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/The-2018-Streaming-Media-European-Readers-Choice-Award-Winners-127092.aspx" style="font-weight:bold;">The 2018 Streaming Media European Readers’ Choice Award Winners</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_3_ctl00_rptArticles_ctl04_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/UK-Media-Regulator-Calls-for-British-Netflix--126431.aspx" style="font-weight:bold;">UK Media Regulator Calls for British Netflix</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_3_ctl00_rptArticles_ctl05_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/Vote-Now-in-the-2018-Streaming-Media-Readers-Choice-Awards-126193.aspx" style="font-weight:bold;">Vote Now in the 2018 Streaming Media Readers' Choice Awards</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_3_ctl00_rptArticles_ctl06_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/As-Brexit-Looms-UK-Creative-and-Media-Tech-Industries-at-Risk-126014.aspx" style="font-weight:bold;">As Brexit Looms, UK Creative and Media Tech Industries at Risk</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_3_ctl00_rptArticles_ctl07_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/Childrens-OTT-Standing-Out-in-a-Congested-Market-125790.aspx" style="font-weight:bold;">Children’s OTT: Standing Out in a Congested Market</a></div>
	
		<div>&nbsp;</div>
	

        </div>
        <div id="rcBot3" style="display: none">
          <div class="bloglabel">Recent Streaming Media Global News</div>
            
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_2_ctl00_rptArticles_ctl00_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/Amazon-TV-Device-Owners-Are-Happier-With-Amazon-Prime-Video--127070.aspx" style="font-weight:bold;">Amazon TV Device Owners Are Happier With Amazon Prime Video</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_2_ctl00_rptArticles_ctl01_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/European-TV-Watching-Shifts-to-On-Demand-Streamed-Content-126824.aspx" style="font-weight:bold;">European TV-Watching Shifts to On-Demand Streamed Content</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_2_ctl00_rptArticles_ctl02_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/OTT-Providers-Get-Higher-Marks-Than-Pay-TV-for-Customer-Service-126557.aspx" style="font-weight:bold;">OTT Providers Get Higher Marks Than Pay TV for Customer Service</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_2_ctl00_rptArticles_ctl03_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/Asia-Pacific-Region-Will-Have-351M-SVOD-Customers-by-2023-126531.aspx" style="font-weight:bold;">Asia Pacific Region Will Have 351M SVOD Customers by 2023</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_2_ctl00_rptArticles_ctl04_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/Biggest-Netflix-Markets-Outside-U.S.-Nordics-Germany-Australia-126413.aspx" style="font-weight:bold;">Biggest Netflix Markets Outside U.S.: Nordics, Germany, Australia</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_2_ctl00_rptArticles_ctl05_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/The-U.K.-Now-Has-More-SVOD-Than-Pay-TV-Subscriptions-Ofcom-126368.aspx" style="font-weight:bold;">The U.K. Now Has More SVOD Than Pay TV Subscriptions: Ofcom</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_2_ctl00_rptArticles_ctl06_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/BBC-iPlayer-and-BBC-Sport-Serve-66.8M-World-Cup-Streams-126330.aspx" style="font-weight:bold;">BBC iPlayer and BBC Sport Serve 66.8M World Cup Streams</a></div>
	
        <div style="text-align:left;width:150;padding-bottom:6px;padding-top:6px;margin-left:5px;margin-right:5px;"><a id="ctl00_ContentPlaceHolder1_RightColumn_1_ThreeTabbedBox_1_ArticleList_2_ctl00_rptArticles_ctl07_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/Viewers-Average-67-Minutes-of-Online-Video-Per-Day-Says-Zenith-126288.aspx" style="font-weight:bold;">Viewers Average 67 Minutes of Online Video Per Day, Says Zenith</a></div>
	
		<div>&nbsp;</div>
	

        </div>
    </div>
</div>

    </div>

        
<!-- begin doubleclick 160x600 module -->
<script type="text/javascript">
  GA_googleFillSlot("StreamingMediaGlobal-WideSkyscrapers");
</script>
<!-- end doubleclick 160x600 module -->

       </div> 

        
        <div class="box">
        <div class="line">
            <a id="ctl00_ContentPlaceHolder1_RightColumn_1_IssueList_1_ctl00_rptIssues_ctl00_lnkViewCurrentIssue" href="http://www.streamingmediaglobal.com/Issue/8290-Summer-2018.htm"><img src="http://dzceab466r34n.cloudfront.net/Images/IssueImages/117593-Summer-2018-Cover-Image-048.jpg" alt="" /></a>
           <center>
            <h3>
                <span id="ctl00_ContentPlaceHolder1_RightColumn_1_IssueList_1_ctl00_rptIssues_ctl00_CaptionText"><em>Streaming Media</em><br />Magazine</span></h3>
                <span id="ctl00_ContentPlaceHolder1_RightColumn_1_IssueList_1_ctl00_rptIssues_ctl00_lblCurrentIssueName" style="font-weight:bold;">Summer 2018</span>
              <br />
               <a href="/Subscribe" style="font-weight: bold;">Subscribe</a>
               </center>  
        </div>  
        <div class="line" style="display:block; height:13px;">
            <a id="ctl00_ContentPlaceHolder1_RightColumn_1_IssueList_1_ctl00_rptIssues_ctl00_lnkViewIssue" href="http://www.streamingmediaglobal.com/Issue/8290-Summer-2018.htm" style="width: 114px; float:left; font-weight:bold; display:inline-block; ">Current Issue</a>
            <a id="ctl00_ContentPlaceHolder1_RightColumn_1_IssueList_1_ctl00_rptIssues_ctl00_lnkPastIssue" href="http://www.streamingmediaglobal.com/Previous_Issues/" style="width: 100px; float:right; font-weight:bold; display:inline-block; text-align:right">Past Issues</a>
        </div>
        <div class="magazine">
            <ul>
                <li>
                    
        <ul>
    
        <li>
            <a id="ctl00_ContentPlaceHolder1_RightColumn_1_IssueList_1_ctl00_rptIssues_ctl00_ArticleList1_ctl00_rptArticles_ctl01_ArticleTitle" href="http://www.streamingmedia.com/Articles/Editorial/Featured-Articles/Next-Generation-Content-Delivery-The-Shift-Is-Underway-125593.aspx" target="_blank">Next-Generation Content Delivery: The Shift Is Underway</a></li>
    
        <li>
            <a id="ctl00_ContentPlaceHolder1_RightColumn_1_IssueList_1_ctl00_rptIssues_ctl00_ArticleList1_ctl00_rptArticles_ctl02_ArticleTitle" href="http://www.streamingmedia.com/Articles/Editorial/Featured-Articles/Seed-Money-6-Ways-Streaming-Video-Plays-a-Role-in-Farming--123058.aspx" target="_blank">Seed Money: 6 Ways Streaming Video Plays a Role in Farming</a></li>
    
        <li>
            <a id="ctl00_ContentPlaceHolder1_RightColumn_1_IssueList_1_ctl00_rptIssues_ctl00_ArticleList1_ctl00_rptArticles_ctl03_ArticleTitle" href="http://www.streamingmedia.com/Articles/Editorial/Featured-Articles/Content-Licensing-Gets-Complicated-Whos-Minding-the-Store-125704.aspx" target="_blank">Content Licensing Gets Complicated: Who’s Minding the Store?</a></li>
    
        <li>
            <a id="ctl00_ContentPlaceHolder1_RightColumn_1_IssueList_1_ctl00_rptIssues_ctl00_ArticleList1_ctl00_rptArticles_ctl04_ArticleTitle" href="http://www.streamingmedia.com/Articles/Editorial/Featured-Articles/Help-Us-Help-Others-Stream-The-Online-Video-Industry-Gives-Back-125592.aspx" target="_blank">Help Us Help Others Stream: The Online Video Industry Gives Back</a></li>
    
        <li>
            <a id="ctl00_ContentPlaceHolder1_RightColumn_1_IssueList_1_ctl00_rptIssues_ctl00_ArticleList1_ctl00_rptArticles_ctl05_ArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/The-Flux-Before-the-Storm-The-Media-World-Bares-its-FANGs-125794.aspx">The Flux Before the Storm: The Media World Bares its FANGs</a></li>
    
        </ul>
    

                </li>
            </ul>
        </div>

				<hr>
        <p><span style="text-decoration: underline;"><strong>Digital Edition</strong></span></p>
<div><strong>Current Issue:</strong></div>
<div><strong><a title="Streaming Media Magazine - European Edition - Autumn 2018" href="https://flipflashpages.uniflip.com/3/104274/1097384/pub/html5.html" target="_blank">Autumn 2018</a></strong></div>
<div><strong><a title="Streaming Media Magazine - European Edition - Summer 2018" href="https://flipflashpages.uniflip.com/3/104274/1095728/pub/html5.html" target="_blank">Summer 2018</a></strong></div>
<div><strong><a title="Streaming Media Magazine - European Edition - Spring 2018 (Sourcebook)" href="https://interactivepdf.uniflip.com/2/104274/1092370/pub/html5.html#page/1" target="_blank">Spring 2018</a>&nbsp;</strong>(Sourcebook)</div>
<div><strong><a title="Streaming Media Magazine - European Edition - Winter 2017" href="https://interactivepdf.uniflip.com/2/104274/1089131/pub/html5.html" target="_blank">Winter 2017</a></strong></div>
<!--<div><strong><a title="Streaming Media Magazine - European Edition - Autumn 2017" href="https://interactivepdf.uniflip.com/2/104274/1085951/pub/html5.html" target="_blank">Autumn 2017</a></strong></div>

<div><a title="Streaming Media Magazine - European Edition - Autumn 2016" href="https://flipflashpages.uniflip.com/3/104274/371682/pub/html5.html" target="_blank"><br /></a>
<br />
<strong> <a title="Streaming Media Magazine - European Edition - Winter 2015" href="https://flipflashpages.uniflip.com/3/104274/372813/pub/html5.html" target="_blank">Winter 2015</a></strong> -->


    </div>
    

    
    <br />
</div>

    <div id="bdyMid_page">
        <div class="title">
            <span id="ctl00_ContentPlaceHolder1_ArticleTitle">OTT Moves Toward Microservices as Speed Becomes an Issue</span>
        </div>
        <div class="deck">
            <span id="ctl00_ContentPlaceHolder1_ArticleSummary">Microservices architectures are central to the growth of OTT services, but they're widely misunderstood. Here's an intro to the major players. </span>
        </div>
        <div class="byline">
            <div class="date">
                
                        By
                    
                        <a id="ctl00_ContentPlaceHolder1_rptAuthors_ctl01_Author" class="ArticleAuthor" href="http://www.streamingmediaglobal.com/Authors/4268-Dom-Robinson.htm">Dom Robinson</a>
                    
                <br />
                <span>Posted on August 31, 2018</span>
            </div>
        </div>
        <div class="pageNav">
            
            Page 1 of 2
            <a id="ctl00_ContentPlaceHolder1_NextPage1" class="readarticle_articlepagecontrol" href="http://www.streamingmediaglobal.com/Articles/ReadArticle.aspx?ArticleID=127125&amp;PageNum=2">next »</a>
        </div>
        
        <div style="float: left;padding:4px 10px 0 0;">
            <div><img src="http://dzceab466r34n.cloudfront.net/Images/ArticleImages/117638-Microservices-145.jpg?display=thumb" border='0'></div>
            
                


            
        </div>
        <p>Historically, the amount of investment into innovation in streaming technology was limited to the very largest software vendors in the space. Microsoft, Adobe, and Real were, for some time, the only game in town. Their technologies were often tied to specific chip architectures and operating systems. The only option operators had was to deploy these technologies onto dedicated machines. Once deployed, the only way to offer any redundancy was to simply double up the infrastructure. And, of course, all of that led to a complex balance of maintaining availability while not sinking vast sums into unused infrastructure.</p><p>According to the traditional broadcast mindset, this was &ldquo;how things had always been done.&rdquo; And for many years, the industry had the advantage of dictating what the end-user devices,and the networks that reached those devices, would be.</p><p>But today&rsquo;s smartphone generation does not care about corporate strategy. It cares only about being able to get hold of the content they want to consume, and if that content, ready for their device, is not easy to find through a well-known operator&rsquo;s offering, then the user has no hesitation in looking for that content on an alternative (sometimes less-than-legal) platform.</p><p>Operators that want to run alongside those users and keep them engaged have eventually faced a choice: either create more new infrastructure and leave the legacy infrastructure to decay, then rinse and repeat, or move to a virtualised model where the right infrastructure can be dialed up in a few moments and retired as soon as it becomes economically inefficient.</p><p>But not all virtualised models are the same.</p><h2><strong>Image/Virtual Machine</strong></h2><p>The most familiar virtualisation model is the replication of a machine image into a virtual host (one where multiple separate machine images may be running). Essentially a full computer image, including all the software and operating system (a virtual machine, or VM), is transferred to the virtual host, which then launches that computer with its own isolated access to memory and CPU drivers, and then, through the virtual host, access to the underlying hardware in a way that &ldquo;shares&rdquo; that hardware resource with other VMs operated by the virtual host.</p><p>This approach is simple to understand for a user familiar with his or her own desktop machine: &ldquo;Take a snapshot of the desktop, transfer to the virtual host, boot and remotely log in, then carry on.&rdquo;</p><p>The logical simplicity of this VM model is not without benefits. Each VM contains its own operating system (OS), and this gives the developer flexibility and freedom to define their own environment. For this reason, a virtual host can usually support a mix of machines, with one being a Linux machine, another being a Windows Server, and yet another being a different version of Linux or potentially something else altogether, etc. This provides flexibility.</p><p>However, this approach is also very resource-inefficient. VMs are large&mdash;OS kernels are rarely small&mdash;and each VM kernel must launch its own resource, which runs on its own. In practice, no matter how much you optimise that VM kernel, it will still consume significant cycles of CPU and orders of GB of available memory.</p><p>In addition, while there are unsupported open source options, virtual hosts (sometimes called &ldquo;hypervisors&rdquo;) are a very expensive software when provided with support.</p><p>From a network operations aspect, moving the VM to the virtual host may take some time, and each boot up may take some further seconds, if not minutes, to occur. That&rsquo;s time that is likely to cause some stress during a critical live sports broadcast if that unit&rsquo;s boot time is critical. So even today, over-the-top (OTT) operators delivering mission-critical live broadcasts using VM-based virtualisation still typically run everything with at least 1:1 redundancy if not 1:1+n.</p><h2><strong>Linux LXC</strong></h2><p>In February 2007, kernel-based virtual machines (KVMs) were introduced to the Linux kernel mainline release, meaning that any installation of that kernel forward could be set up to be a virtual host for VMs.</p><p>By 2008, a slightly different approach was emerging, and although there were numerous virtualisation efforts going on, Linux Containers (LXC) typified where thinking was moving and, to some extent, popularised the term &ldquo;containers.&rdquo;</p><p>LXC offers many of the benefits of virtualisation, but with some limits: the underlying OS is a specific &ldquo;shared&rdquo; Linux kernel. This single underlying OS replaces both the role of the virtual host in the VM paradigm and, importantly, that of the guest VM image&rsquo;s OS.</p><p>All the guest image contains is the differences (deltas) from the LXC host distribution that it is launched on. That would include, for example, any session-specific information and the application itself.</p><p>These collections of deltas have become known as &ldquo;containers.&rdquo; In contrast to a VM, a container can be transferred over a network much more quickly to the host, or can even be locally cached for increased launch efficiency.</p><p>In a network environment where you can ubiquitously dictate the network fabric&rsquo;s virtual host kernel (such as in an ISP, a cloud, or a telecoms network), this opens the architectural opportunity to create libraries/registries of containers, each set up in a specific way or each capable of fulfilling very specific functions, capable of collectively delivering the function of a native monolithic application (a container can launch about as quickly as a native application, since there is no OS or kernel to boot), and yet with all the benefits of virtualisation such as process and memory isolation, scalability, and increased availability.</p><p>Many larger organisations were already using service-oriented architecture approaches in order to scale. Small functions could be launched and composed into workflows that delivered complete network applications equivalent to that of a traditional monolithic application. With the newfound granular ability to scale only those parts of the workflow that mattered, this offered a new approach, particularly for any operator focused on network and distributed computing. Function could be specifically scaled up to meet demand, and with some density of resources that the traditional monolith could not offer.</p><p>Over time, and particularly as containers have popularised ideas about highly distributed function, people have started to talk a lot about microservices architectures (MSAs). While the vernacular term is commonly &ldquo;microservices,&rdquo; I want to generally use the abbreviation of MSA from here on to keep the big picture of architecture in our minds.</p><p>It&rsquo;s important to note that while containers have become a popular new way to package and deploy microservices, they were not, in and of themselves, enabling anything particularly new in the space.</p><p>It is also worth noting that containers are very useful from the point of view of an infrastructure provider (such as a public cloud provider or telco), since a container approach allows third-party access to its infrastructure in a heterogenous way and in a way where it can provision containers and better share the resource among multiple use-cases.</p><p>However, MSA delivered <em>without</em> containers may be simpler to deploy for an operator that is using their own infrastructure and is not worried about multi-tenant isolation or container resource quotas, and who may want direct access to specific hardware functions in the infrastructure, such as field-programmable gate arrays (FPGAs) or graphics processing units (GPUs). So in some situations, containers can actually add complexity to the MSA, and while they are almost synonymous in current marketing-speak, it is important to understand the distinction at a technical level.</p><p>Before we look at some MSA strategies and technologies that are being adopted by the OTT and streaming industry, let us quickly summarise understanding so far:</p><h2><strong>Understanding Microservices Architecture</strong></h2><p>Microservices each compose some element of a wider application and communicate over a network (be it some fancy service bus or a nice, simple HTTP interface), and this approach has been around a while with the following goals:</p><ul><li>Smaller, self-contained services become easier to test than a large monolith.</li><li>The isolation between services means that one going bad is far less likely to take down anything else.</li><li>Provided it stays backwards-compatible, it allows each service to evolve and move forward relatively independently of the others. For example, Amazon&rsquo;s recommendation engine doesn&rsquo;t end up tied to the lifecycle of the checkout process.</li><li>Breaking up the monolith makes it simpler to scale the aspects of the overall application that are the bottlenecks &ldquo;simply&rdquo; by launching more instances of them on additional hardware.</li></ul><p>Although &ldquo;simply&rdquo; in that last bullet point is making light of the that fact that this can frequently actually be a very complex thing to do (due to state management&mdash;for example, scaling the database of what resource is doing what for who is not as simple as &ldquo;just launching a second instance&rdquo;), it is still without a doubt easier than it would be in the monolith world.</p><h2><strong>Common Strategies</strong></h2><p>This architectural approach sounds like a simple adjustment of thinking, but in practice, it has taken a long time for the traditional broadcast culture to take an interest in the benefits above.</p><p>Recent rapid consumer adoption has given a new urgency to all levels of content delivery optimisation, and MSA has suddenly not only become relevant but become central to all forward-thinking, scalable, and efficient strategies for meeting that explosion of demand.</p><p>However, given that software strategies can be implemented in an almost infinite number of ways, there are numerous &ldquo;pools&rdquo; of approaches emerging in the real world of MSA implementation.</p><p>This is a roundup of some of the key players that are active in the OTT space. It is far from exclusive, but we have included one or two links to help you explore further.</p><p><strong>ETSI NFV/SDN AND MEC</strong></p><p><a href="https://www.etsi.org/" target="_blank">ETSI</a> is the European Telecommunications Standards Institute, which has an initiative running called Network Functions Virtualisation/ Software Defined Networking (NFV/SDN). The idea is that if carriers are increasingly going to start to deploy reprogrammable fabric within the telecoms network, then the fabric must run an increasingly diverse range of functions. To deploy network architectures as flexibly as possible, alignment between vendors and operators, especially in terms of the application programming interface (API) between all the components, is a useful standards track to follow. Likewise, the Mobile Edge Compute (MEC) initiative, renamed the Multi-Access Edge Compute about 18 months ago, is looking at taking that standardisation out to the radio access networks of cellular and Wi-Fi operators, ensuring there is an ecosystem that telcos and vendors, and, subsequently, their clients, can use to build the networks of tomorrow using MSA as a first principle.</p><p>Adoption and adherence to ETSI NFV/SDN comes in fits and starts on the show floor at events like NAB and IBC. Moving from demo or trial to production requires significant buy-in from those teams that need to provision fabric capable of running microservices out deep in edges.</p><p>However, natural churn as edge technology is replaced or updated means that ETSI&rsquo;s forward thinking is a strong reference point for vendors, developers, and operators alike.</p><p><strong>DOCKER</strong></p><p>Developing against Linux LXC directly can be a reasonably involved effort. <a href="https://www.docker.com/" target="_blank">Docker</a> gave Linux LXC usability for the general user. When Docker was publicly released, open source, in 2013, the timing was just right. Docker made it straightforward to set up an environment into which you could deploy a Linux container, and notably the Docker name, philosophy, and even logo are all about extending the paradigm of containers and the underlying logistics of distributing them. Docker moved on from LXC in 2014, introducing its own execution driver libcontainer which is not architecturally tied to Linux (<a href="https://blog.docker.com/2014/03/docker-0-9-introducing-execution-drivers-and-libcontainer/" target="_blank">see this blog post for more about that</a>).</p><p>Container execution is not the only part of the MSA model. Microservices on their own are easy to think of as atomically small functions wrapped in a container. I have heard it said that &ldquo;containers on their own are useless, it is the orchestration and scheduling that make the strategy valuable&rdquo;&mdash;hence &ldquo;MSA&rdquo; is more accurate than &ldquo;microservices.&rdquo; Without the ability to compose those microservices into a useful function for your operation, they are essentially unbuilt LEGOs!</p>
        <div class="readarticle_currentpage pageNav" style="float: right; margin-bottom: 5px;">
            
            Page 1 of 2
            <a id="ctl00_ContentPlaceHolder1_NextPage2" class="readarticle_articlepagecontrol" href="http://www.streamingmediaglobal.com/Articles/ReadArticle.aspx?ArticleID=127125&amp;PageNum=2">next »</a>
        </div>
        <div style="padding:10px 0 5px 0;"><div class="fb-comments" data-href="http://www.streamingmediaglobal.com/Articles/ReadArticle.aspx?ArticleID=127125" data-width="658"></div>
</div>        
        <div style="clear:both;">
            
        <div class="title" style="padding-bottom:5px;width:160;text-align:left;"><span id="ctl00_ContentPlaceHolder1_alRelatedArticles_ctl00_rptArticles_ctl00_CaptionText">Related Articles</span></div>
	
        <div style="text-align:left;width:160;padding-top:6px;"><a id="ctl00_ContentPlaceHolder1_alRelatedArticles_ctl00_rptArticles_ctl01_RelatedArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/OTT-Revenues-to-Nearly-Double-in-5-Years-Finds-Juniper-Research-122234.aspx" style="font-weight:bold;">Featured News: OTT Revenues to Nearly Double in 5 Years, Finds Juniper Research</a></div>
        <div style="text-align:left;width:160;padding-bottom:6px;font-size:10px;font-style:italic;"><span id="ctl00_ContentPlaceHolder1_alRelatedArticles_ctl00_rptArticles_ctl01_ArticleSummary">The subscription services are fueling their rise with lavish original content budgets, outspending traditional broadcasters.</span></div>
	
        <div style="text-align:left;width:160;padding-top:6px;"><a id="ctl00_ContentPlaceHolder1_alRelatedArticles_ctl00_rptArticles_ctl02_RelatedArticleTitle" href="http://www.streamingmediaglobal.com/Articles/News/Featured-News/Trends-That-Will-Shape-2018-Include-Post-OTT-Convergence-and-AI--123339.aspx" style="font-weight:bold;">Featured News: Trends That Will Shape 2018 Include Post-OTT Convergence and AI </a></div>
        <div style="text-align:left;width:160;padding-bottom:6px;font-size:10px;font-style:italic;"><span id="ctl00_ContentPlaceHolder1_alRelatedArticles_ctl00_rptArticles_ctl02_ArticleSummary">Nagra details five trends it says will shape how companies deliver-and how consumers purchase-TV in the coming year.</span></div>
	
        <div style="text-align:left;width:160;padding-top:6px;"><a id="ctl00_ContentPlaceHolder1_alRelatedArticles_ctl00_rptArticles_ctl03_RelatedArticleTitle" href="http://www.streamingmediaglobal.com/Articles/Editorial/Featured-Articles/Childrens-OTT-Standing-Out-in-a-Congested-Market-125790.aspx" style="font-weight:bold;">Featured Articles: Children’s OTT: Standing Out in a Congested Market</a></div>
        <div style="text-align:left;width:160;padding-bottom:6px;font-size:10px;font-style:italic;"><span id="ctl00_ContentPlaceHolder1_alRelatedArticles_ctl00_rptArticles_ctl03_ArticleSummary">OTT services targeting kids need to keep four things in mind: content, convenience, user experience, and safety.</span></div>
	
		<div>&nbsp;</div>
	

        </div>
    </div>

            </div>

            <!-- begin sponsored link module -->
            <div class="sponlinkbox">
                <div class="sponlinkhdr">SPONSORED LINKS</div>
                <div class="sponlink">
                    
		<a id="ctl00_TextLinksList_ctl00_rptTextLinks_ctl00_TextLink" href="http://tracking.onlineinc.com/sponsorhit.aspx?sponsorship_id=30757" target="_blank" style="font-weight:bold;">Unisphere Research - Delivering Certainty Through In-Depth Analysis of Enterprise Technology, IT, Marketing &amp; Media Trends</a>
	

                </div>
            </div>
            <!-- end sponsored link module -->

        </div>


        <!-- begin footer module -->
        <div id="footerWrapper">
            <div class="container">
                <div id="footer">
                    <div id="ftrLeft" class="ftrMenu">
                        <div class="ftrHeadline">
                            INSIDE STREAMING MEDIA EUROPE
                        </div>
                        <div class="ftrPad ftrFloatL">
                            <ul>
                                <!--<li><a href="http://www.StreamingMediaEurope.net" target="_blank">Blog</a></li>-->
                                <li><a href="http://www.streamingmediaglobal.com/Previous_Issues"><em>SM</em> Magazine</a></li>
                                <li><a href="http://www.streamingmediaglobal.com/Previous_Issues"><em>SM</em> Digital Edition</a></li>
                                <!--<li><a href="http://www.streamingmediaglobal.com/StreamingMediaTV">Streaming Media TV</a></li>-->
                                <li><a href="http://www.streamingmediaglobal.com/ConferenceVideos">Conference Videos</a></li>
                                <li><a href="http://www.streamingmediaglobal.com/Tutorials">Video Tutorials</a></li>
                                <li><a href="http://www.streamingmediaglobal.com/ReadersChoice">Readers Choice</a></li>
                                <!--<li><a href="">Podcasts</a></li>-->
                                <!-- <li><a href="http://www.streamingmediaglobal.com/Research">Research Reports</a></li> -->
                                <li><a href="http://www.streamingmediaglobal.com/PressRelease/">Press Releases</a></li>
                                <li><a href="http://www.streamingmediaglobal.com/WebEvents">Web Events</a></li>
                                <li><a href="http://www.streamingmediaglobal.com/EventsDiary">Events Diary</a></li>
                            </ul>
                        </div>
                        <div class="ftrFloatR">
                            <ul>
                                <li><a href="http://www.streamingmediaglobal.com/Newsletters">Newsletters</a></li>
                                <li><a href="http://www.streamingmediaglobal.com/Articles/News">Industry News</a></li>
                                <li><a href="http://www.streamingmediaglobal.com/Whitepapers">Superguides</a></li>
                                <li><a href="http://www.streamingmediaglobal.com/SponsoredContent">Industry White Papers</a></li>
                                <!--<li><a href="http://forums.streamingmedia.com/">Forums</a></li>-->
                                <li><a href="http://www.streamingmediaglobal.com/Sourcebook">Industry Directory</a></li>
                                <li><a href="http://www.streamingmediaglobal.com/Jobs">Industry Jobs</a></li>
                                <li><a href="http://www.streamingmediaglobal.com/About/About_Us">About Us</a></li>
                            </ul>
                        </div>
                    </div>
                    
<div id="ftrMid" class="ftrMenu">
    <div class="ftrHeadline">
        RESEARCH CENTERS</div>
        <div class="ftrPad ftrFloatL"><ul><li><span class="ftrMenuhead">TOPICS</span><ul><li><a href="http://www.streamingmediaglobal.com/Categories/Legal-Issues_448.aspx">Legal Issues</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Live-Streaming_579.aspx">Live Streaming</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Mobile-Video_444.aspx">Mobile Video</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Music-Radio_445.aspx">Music/Radio</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Online-Video-Platforms_446.aspx">Online Video Platforms</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/OTT-Video_443.aspx">OTT Video</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Video-Advertising_440.aspx">Video Advertising</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Video-Content-Creation-Production_438.aspx">Video Content Creation/Production</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Video-Content-Protection-DRM_441.aspx">Video Content Protection/DRM</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Video-Encoding-Transcoding_439.aspx">Video Encoding/Transcoding</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Video-Formats-Players-Codecs_442.aspx">Video Formats/Players/Codecs</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Video-Hosting-Delivery_437.aspx">Video Hosting/Delivery</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Video-SEO_447.aspx">Video SEO</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/VR-and-360deg%3b-Video_590.aspx">VR and 360&deg; Video</a></li></ul></li></div><div class="ftrPad ftrFloatL"><ul><li>&nbsp;<ul></ul></li></div>
        <div class="ftrFloatL"><ul><li><span class="ftrMenuhead">VERTICALS</span><ul><li><a href="http://www.streamingmediaglobal.com/Categories/Education-Video_452.aspx">Education Video</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Enterprise-Video_450.aspx">Enterprise Video</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Government-Video_453.aspx">Government Video</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Media-Entertainment-Video_451.aspx">Media/Entertainment Video</a></li><li><a href="http://www.streamingmediaglobal.com/Categories/Online-Video-Industry_449.aspx">Online Video Industry</a></li></ul></li></div>
</div>

                    <div id="ftrRight" class="ftrMenu">
                        <div class="ftrHeadline">
                            OTHER ITI SITES
                        </div>
                        <ul>
                            <li><a href="http://www.StreamingMedia.com/">StreamingMedia.com</a></li>
                            <li><a href="http://www.StreamingMedia.com/Producer">Streaming Media Producer</a></li>
                            <li><a href="http://www.destinationCRM.com/" target="_new">destinationCRM</a></li>
                            <li><a href="http://www.econtentmag.com/" target="_new">EContent</a></li>
                            <li><a href="http://www.faulkner.com/" target="_new">Faulkner Information Services</a></li>
                            <li><a href="http://www.InfoToday.com/" target="_new">Information Today</a></li>
                            <li><a href="http://www.InfoToday.eu/" target="_new">Information Today Europe</a></li>
                            <li><a href="http://www.kmworld.com/" target="_new">KMWorld</a></li>
                            <li><a href="http://www.SmartCustomerService.com/" target="_new">Smart Customer Service</a></li>
                            <li><a href="http://www.speechtechmag.com/" target="_new">Speech Technology</a></li>
                            <li><a href="http://www.UnisphereResearch.com/" target="_new">Unisphere Research</a></li>

                        </ul>
                    </div>
                </div>
                <div id="copyright">
                    &copy; 2000 -
                    2018, Streaming Media Europe, an Information Today, Inc. (ITI) company<br />
                    <br />
                    <a style="color: #FFFFFF; text-decoration: none; font-size: 16px;" href="http://www.infotoday.eu/privacy.aspx" target="_new">[PRIVACY/COOKIES POLICY]</a><br />
                </div>
            </div>
        </div>

        <script>

            function btnRC1(group, id) {
                var pc = 0;
                var tab;
                if (group == "rcTop") {
                    pc = 3;
                }
                if (group == "rcBot") {
                    pc = 3;
                }
                if (pc == 0)
                    return;


                for (n = 1; n < pc + 1; n++) {
                    buf = group + n;
                    tab = group + "Li" + n;
                    if (n == id) {
                        document.getElementById(buf).style.display = "block";
                        document.getElementById(tab).className = "tabOn";
                    }
                    else {
                        document.getElementById(buf).style.display = "none";
                        document.getElementById(tab).className = "tabOff";
                    }
                }

            }
        </script>

        <script type="text/javascript">
            var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
            document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
        </script>

        <script type="text/javascript">
            var pageTracker = _gat._getTracker("UA-13073004-3");
            pageTracker._initData();
            pageTracker._trackPageview();
        </script>
        <script type='text/javascript'>
            GA_googleFillSlot("StreamingMediaGlobal-Interstitial");
        </script>
        <!-- end footer module -->
        <!-- AddThis Smart Layers BEGIN -->
        <!-- Go to http://www.addthis.com/get/smart-layers to customize -->
        <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=itisharing"></script>
        <script type="text/javascript">
            addthis.layers({
                'theme': 'light',
                'share': {
                    'position': 'left',
                    'numPreferredServices': 6
                },
            });
        </script>
        <!-- AddThis Smart Layers END -->


    </form>
</body>
</html>
